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[bookmark: _Toc17191590]Introduction
Welcome! This guide describes how to get started using Drupal, the content management system used to publish on the ‘For government’ site (www.qld.gov.au/gov). It covers basic topics such as registering for an account, logging in, changing your account settings, and creating content.
1 [bookmark: _Toc17191591]Request an account
To get an account, you must be a ‘For government’ certified author and have completed induction and training. Email the Customer Online team (qssdigitalproducts@dsiti.qld.gov.au) to request a new account or to enquire about training.
2 [bookmark: _Toc17191592]Roles and user accounts
There are three types of users:
Anonymous user—government employees can access secure content (pages that have been made private) by logging in. You must have a qld.gov.au email address, or other approved email address to create a login.
Content editor/approver—content authors create and publish content on the ‘For government’ website. To become a content editor/approver you need to complete the ‘For government’ Content Author Training.  The Customer Online team will give you access to the CMS related to your area of work.
Site editor—Customer Online team members with access to all of the CMS.
3 [bookmark: _Toc17191593]Logging in
To log in:
Go to www.forgov.qld.gov.au/user/login.  
Enter your username (your email) and password.
Click Log in.
If you have forgotten your password, click Request new password and follow the prompts.
[image: C:\Users\brewstlz\Desktop\drupal-screens\login.png]
4 [bookmark: _Toc17191594]Changing your password
To change your password:
Log in to Drupal.
In My Workbench under My Profile, click edit my profile.
Enter your current password, new password and confirm.
Click Save.
[image: C:\Users\brewstlz\Desktop\drupal-screens\edit-profile.png]
5 [bookmark: _Toc17191595]Content types
[image: ]
There are several content types within Drupal: 
Document—Manage government directives, policies, guidelines, standards and circulars.
Event—Use Events to inform viewers of upcoming/archived events.
Knowledge sharing group—Use to inform visitors of your government working group, community of practice or special interest group.
News story—Publish a news story for government employees.
Product page—Used to display general, technical, contact and support information for product or services.
Project—Use to give visitors an overview of current projects in your organisation.
Section page—Used as section/sub-sections that act as structural jump points to content below.
Standard page—Use this content type for standard informational content or ‘outcome’ pages.
Webform—Create a new form or questionnaire accessible to customers. Submission results and statistics are recorded and accessible to privileged users.
6 [bookmark: _Toc17191596]Site structure overview
The Main menu is the sitemap of the entire ‘For government’ site, displaying the hierarchy of pages.
To view the Main menu:
Click Structure > Menus > list links
Tip: Bookmark the main menu page for easy access.
[image: C:\Users\brewstlz\Desktop\drupal-screens\structure1.png]
[image: C:\Users\brewstlz\Desktop\drupal-screens\structure4.png]
7 [bookmark: _Toc17191597]Create and edit content pages
[bookmark: _Toc17191598]Create a new page
[image: ]
Click Menu > Content > Add Content.
Select the required page type. Visit Design and promote For government content to read more about our Page types to help decide which one is right for your content.
[bookmark: _Create_Standard_page][bookmark: _Create_a_standard][bookmark: _Toc17191599]Create a standard page
[image: ]
Click > Standard page.
Type a meaningful, customer-centric Title.
Insert an Image Icon by clicking Browse (Icons appear on index pages):
Go to the Image location on your computer. Select the image and click Open. 
Click Upload > Next > Add Alt Text > Save.
Type a Summary. This displays on the section page where your content will be linked, and in search results.

[image: ]

Type the Body. This is the main part of your article and will be viewable to everyone. 
Note: if you want content viewable to specific agencies, leave the Body section blank and refer to the Add a paragraph type section of this document for steps to create agency-specific Forked content.

If required, update the Privacy setting for the page:
Default—inherits setting of page ancestor(s).
Public—visible to all
Private—Only visible to logged in, registered users.
[image: ]
Select the appropriate Creative Commons Licence for your content. The default None applies the least restrictive licence type.
Select Menu Settings and tick Provide a Menu Link.
Select a Parent item from the drop-down menu. This will be a section page, where your content belongs within the IA and will be linked.
Select Meta tags and update the metadata for your new page as required:
Add Keywords.
Add Creator (your agency name) under Dublin Core Basic Tags > Creator in the Value field.
[image: ]
Select Publishing options:
[bookmark: _Hlk513730548]Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
Insert the Review email address of the team responsible for the page.
Save and check how it looks. If the page displays correctly, publish now (Change the Moderation state to Published and Save), or schedule for a future date.
[bookmark: _Toc17191600]Create a case study page
[image: ]
1 Click > Standard page.
2 Complete the steps covered under Create a standard page above.
3 When you complete the Body content:
3.1 Format all quotes as pull quotes.
3.2 Insert and format images as cut-ins.
3.3 Embed and format video.

Note: if you want content viewable to specific agencies, leave the Body section blank and refer to the Add a paragraph type section of this document for steps to create agency-specific Forked content.

4 Select Optional componenets.
5 Add an aside to the page to display related case studies:
5.1 In the Aside type dropdown, choose Aside and click Add new Aside.
5.2 Add a title: Find similar initiatives.
5.3 In the Aside content field click the Source button
5.4 Paste the following code


<div class="case-study-tags">.</div>

5.5 Click the Source button.
6 Select Add Preamble.
7 Insert a background image (this will appear as a header image to the article) by clicking Browse. The image must be between 600x90 and 800x800 pixels.
8 Type a meaningful, customer-centric Subtitle. This will appear, along with the title of the artilce, superimposed over the background image.

[image: ]

9 Select Case Study.
10 Click Add Case study metadata and select all fields that apply.
10.1 For the Main priority and Main principle metadata, select from the dropdowns as appropriate, and then select the same priority or principle in the Priorities and Principles checklists. Add any additional priorities or principles by selecting multiple check boxes.

Example: one priority
[image: cid:image001.png@01D425A3.FD0F43C0]
	Example: multiple priorities
[image: cid:image002.png@01D425A3.FD0F43C0]
11 Continue with the remainder of the Create a standard page steps.
12 Save and check how it looks. If the page displays correctly, publish now (Change the Moderation state to Published and Save), or schedule for a future date.
[bookmark: _Create_a_product][bookmark: _Toc17191601]Create a product page
[image: ]
Click > Product page.
Type a meaningful, customer-centric Title.
Insert an image Icon by clicking Browse (Icons appear on index pages):
Go to the image location on your computer.
Select the image and click Open. 
Click Upload > Next > Add Alt Text > Save.
Type a Product description to summarise the page content.
Add the Topic title by searching for the related page. 
Add the Outcome title by searching for the related page.
Add a form (if required).
Complete the three Product page tabs: 
About
Get started
Contact and support
Select the appropriate Creative Commons Licence for your content. The default None applies the least restrictive licence type.
Select Meta tags and update the metadata for your new page as required:
Add Keywords.
Add Creator (your agency name) under Dublin Core Basic Tags > Creator in the Value field.
Select Publishing options:
Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
[bookmark: _Add_a_form]Insert the Review email address of the team responsible for the page.
Save and check how it looks. If the page displays correctly, publish now (Change the Moderation state to Published and Save), or schedule for a future date.
[bookmark: _Add_content_to]Add a form 
Select the Form type > Product form download.
Click > Add new Form.
Click> Browse > find the form.
Click > Upload.
[image: ]
Choose agencies who this content relates to or leave it blank for all agencies to view it. 
Save and check how it looks. If the page displays correctly, publish.
[image: ]
[bookmark: _Add_a_generic_2]Add a generic paragraph to the About tab
Select > the About tab. 
Choose Paragraph type > Generic markup. 
Select > Add new Paragraph.
Type your text into the Content field.
[image: ]
[bookmark: _Add_Features_to]Add Features to the About tab
Select > Paragraph type > Featured list group.
Add Title > Features.
Add > Feature list item > Edit > Feature list item.
Type a meaningful, customer-centric Title.
Add an Image (Icon to visually represent the title):
To create icons for features:
Go to http://fortawesome.github.io/Font-Awesome/icons/. 
Choose an appropriate icon. 
Copy the whole name (fa-calendar-plus-o).
Go to http://fa2png.io/.
Copy it into the generator, select colour and size (0b2e4c and 50 x 50).
Click Generate.
Click Download.
Upload the icon file into About page.
Type a Summary.
[image: ]
Add additional features to the list > Add another Feature list item.
Add Benefits to the About tab
Select > Paragraph type > Featured list group.
Add Title > Benefit.
Add > Feature list item > Edit > Feature list item.
Add a meaningful and customer-centric Title.
Add an Image (The image used is a Green tick): 
Search in Drupal library for the file name fa-icon (fa-check-square-o-40-0-179824-none-1.png). This is fa-check-square-o, in colour 179824 and size 50x50).
Attach the icon.
Type a Summary.
[bookmark: _Add_a_generic]Add a generic paragraph to the Get started tab
Select > the Get started tab.
Choose Paragraph type > Generic markup. 
Select > Add new Paragraph.
Type your text into the Content field.
[image: ]
[bookmark: _Add_a_generic_1]Add a generic paragraph to the Contact and support tab
Select > the Contact and support tab. 
Choose Paragraph type > Generic markup. 
Select > Add new Paragraph.
Type your text into the Content field.
Add a Contact heading (using Styles).
[image: ]
[bookmark: _Add_FAQs_to]Add FAQs to the Contact and support tab
Add Paragraph > Paragraph type > FAQ embed (used to include FAQs).
Add Title > Support.
Select > FAQ embed view > Select > Knowledge_base_faq – FAQs associated with this content (this will bring in the FAQs that have been associated with this page).
[image: ]

[bookmark: _Creating_a_section][bookmark: _Toc17191602]Creating a section page
[image: ]
To create a new section page, submit your page request to the Customer Design Experience team for approval. Email qsscxdesign@dsiti.qld.gov.au.
The team will ensure the new section page/s are created in consideration to the IA and labelled according to our ‘For government’ principles.
[bookmark: _Toc17191603]Create an event page
[image: ]
Click > Event.
Enter the Event information:
Type a meaningful customer-centric Title.
If the event is hosted on an external platform, such as Eventbrite, enter the Event URL.
Note: This will redirect users to the external platform from the search results page, rather than an event page on For government.
[image: ]
Add information about when the event will start and finish: 
Untick the Show End Date checkbox if you don’t want to show when the event will finish.
Select Add another item if the event will occur more than once.
Enter an RSVP date and cost, if any.
[image: ]
Insert a feature image (559px x 176px) by clicking Browse (optional):
Go to the image location on your computer. Select the image and click Open. 
Click Upload > Next > Add Alt Text > Save.
Tick the Open registration checkbox if you want to manage registrations using the CMS.[image: ]
Type a location for the event. You can also display a map on the event page by entering an Address.[image: ]
Type a Summary and Description of the event. The summary will appear in event search results and in the calendar appointment for the event (if the CMS is used for registrations). You can leave the Summary blank to use a trimmed version of the description text.
Type Contact details for the event organiser.
Select the appropriate Audience setting from the drop-down lists.
If required, update the Privacy setting for the event:
Default—inherits setting of page ancestor(s).
Public—visible to all
Private—Only visible to logged in, registered users.
[image: ]
Select the appropriate Creative Commons Licence for your content. The default None applies the least restrictive licence type.
Select Meta tags and update the metadata for your new page as required:
Add Keywords.
Add Creator (your agency name) under Dublin Core Basic Tags > Creator in the Value field.
Select Publishing options:
Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
Insert the Review email address of the team responsible for the page.
Save and check how it looks. If the page displays correctly, publish now (Change the Moderation state to Published and Save), or schedule for a future date.
[bookmark: _Toc17191604]Create a knowledge sharing group page
[image: ]
Click > Knowledge sharing group page.
Type a meaningful, customer-centric Title and Summary, and select the Lead agency from the drop-down list.
Select About the group. Type a Description of the group, and select Topics from the topic list.
Select Attendees. Describe who the group is intended for, including any restrictions on membership.
Select Outcomes. Explain the intended outcomes from the group.
Select Meeting frequency for the group and when the next meeting will occur. You can add a link to an Event page for the group’s next meeting.
Select Contacts and complete the contact information for the group’s organiser.
Select Associated information and add a link to an external site or For government page where the associated information is hosted.
Note: if you’re creating a page for this purpose, use a standard page that is not attached to the site IA and only host recent documents (meeting agendas, minutes, actions etc.).
You can also add asides to the page, including a Related Events listing.[image: ]
If required, update the Privacy setting for the page:
Default—inherits setting of page ancestor(s).
Public—visible to all
Private—Only visible to logged in, registered users.
[image: ]
Select the appropriate Creative Commons Licence for your content. The default None applies the least restrictive licence type.
Select Meta tags and update the metadata for your new page as required:
Add Keywords.
Add Creator (your agency name) under Dublin Core Basic Tags > Creator in the Value field.
Select Publishing options:
Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
Insert the Review email address of the team responsible for the page.
Save and check how it looks. If the page displays correctly, publish now (Change the Moderation state to Published and Save), or schedule for a future date.
[bookmark: _Create_a_project][bookmark: _Toc17191605]Create a project page
[image: ]
Click > Project page.
Enter the Project Information: 
Type a meaningful, customer-centric Title.
Select the relevant Categories and Lead agency from the lists.
Enter the project’s Start date and expected End date.
Select Project details:
Type a Summary—a short description of the project (maximum 250 characters) that will display in project search results.
Type a longer description of the project in the About the project field. This will display on the project’s page.
Select the Agencies involved from the list.
Type a brief description of how agencies will benefit from the project in the Benefits field.
Type dates for upcoming key milestones in the Key milestones field. Examples include testing and go-live dates. If entered, you must review these dates regularly to ensure they are current.
Select Project phase and type, using a maximum of 150 characters, the stage of the project. If entered, you must review the phase regularly to ensure information is current.
Select Supporting material (if any):
Up to 5 supporting Documents can be uploaded.
Add Links to intranets, external websites or the ICT Dashboard.
Select Contact and add the contact information for the project team.
You can also add asides to the page, including a Related Events listing.
If required, update the Privacy setting for the page:
Default—inherits setting of page ancestor(s).
Public—visible to all
Private—Only visible to logged in, registered users.
[image: ]
Select the appropriate Creative Commons Licence for your content. The default None applies the least restrictive licence type.
Select Meta tags and update the metadata for your new page as required:
Add Keywords.
Add Creator (your agency name) under Dublin Core Basic Tags > Creator in the Value field
Select Publishing options:
Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
Insert the Review email address of the team responsible for the page.
Save and check how it looks. If the page displays correctly, publish now (Change the Moderation state to Published and Save), or schedule for a future date.
[bookmark: _Create_a_news][bookmark: _Toc17191606]Create a news story
[image: ]
1 Click > News story.
2 Add a meaningful, customer-centric Title.
3 Select the most relevant Category from the drop-down list.
[image: ]
4 Type a Summary—a short description of the article (maximum 250 characters) that will display in search results.
5 Type the Body  of the artilce—the main content of the article.
Note: if you want content viewable to specific agencies, leave the Body section blank and refer to the Add a paragraph type section of this document for steps to create agency-specific Forked content.

6 Type Contact details for further information and enquiries.
7 Select the appropriate Creative Commons Licence for your content. The default None applies the least restrictive licence type.
8 Select Meta tags and update the metadata for your new page as required:
8.1 Add Keywords.
8.2 Add Creator (your agency name) under Dublin Core Basic Tags > Creator in the Value field
9 Select Publishing options:
9.1 Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
9.2 Insert the Review email address of the team responsible for the page.
10 Save and check how it looks. If the page displays correctly, publish.
[bookmark: _Toc17191607]Create a whole-of-government document
Use these instructions to publish to Search for directives, policies and guidelines. A whole-of-government document can fall into one of the following categories:
Directive
Policy
Standard
Guideline
Circular
[image: ]
1 Click > Document.
2 Add a meaningful, customer-centric Title.
3 Select the Document type.
4 Where applicable, add the Directive number (if it’s a directives or circular).
5 Where applicable, add a Supersede (if the new directive of curcular replaces an older version/s).
5.1 Search using the directive/circular number.
5.2 Click on the displayed match.
5.3 Click Add another item to add additional Supersedes.
6 Select the Category.
Note: All PSC and IR documents belong in the HR and Industrial relations category

7 Select the Responsible agency.
[image: ]

8 Select Document satus. The default status is Current.
Note: If you are creating a document that supersedes another, you will need to edit the superseded document and change the status of that document to Superseded. You will also need to add an End Date.
 
9 Add an Effective date.
[image: ]
10 Select File uploads.
11 Upload a PDF and DOC version of your document. If the documents are over 1MB, you’ll need to split these into smaller less than 1MB documents. Then upload the split documents via Split PDF version and Split DOC version.
12 Add a thumbnail if you want to override the auto-generated thumbnail.[image: ]
13 Select Summary. This will display in search results and on the documents html page that is generated once the document is published. It should be as short as possible; only the first 197 charactes (including spaces) will display in the search result.[image: ]
14 Select Related information if there are additional online resources that support the policy or directive, or if the document refers directly to exisiting online content.
14.1 Add the Title and URL. If the content is on For government, click Search and find the content. Click Insert link.
14.2 Add Related documents. Click Browse and upload, link or attach the document/s as applicable.
15 Select Optional components and add a status alert and/or asides where applicable.
16 If required, update the Privacy setting for the page:
16.1 Default—inherits setting of page ancestor(s).
16.2 Public—visible to all
16.3 Private—Only visible to logged in, registered users.
[image: ]
Select the appropriate Creative Commons Licence for your content. The default None applies the least restrictive licence type.
17 Select Meta tags and update the metadata for your new page as required:
17.1 Add Keywords.
17.2 Add Creator (your agency name) under Dublin Core Basic Tags > Creator in the Value field
18 Select Publishing options:
18.1 Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
18.2 Insert the Review email address of the team responsible for the page.
19 Save and check how it looks. If the page displays correctly, publish now (Change the Moderation state to Published and Save), or schedule for a future date.
[bookmark: _Toc17191608]Edit an existing page
You can edit an existing page by either finding the page in the content listing within the Drupal content area or navigating the site to your page and selecting New draft or Edit draft (providing you’re logged in).
Edit by content listing
Select Content from the Menu toolbar.
Find the Title of your page and click Edit on the right hand side of the screen.
Tip: If you can’t see your page immediately, use the search filters at the top of the content listing.
[image: ]
Edit by navigating to a page
[image: ]
While logged in, navigate to the page you want to edit.
If your page Moderation State is Published, you can edit by clicking on New Draft.
[image: ]
If your page Moderation State is listed as Draft (Current) or Needs Review, you can edit by clicking on Edit Draft.
[bookmark: _Toc17191609]Publish or save a draft
Once you have created or edited a page:
1 Select Publishing options:
1.1 If you are editing the page, write a brief Log message to explain the changes you have made to the page (new pages auto-populate with you name).
1.2 Enter the current date as the Last Reviewed.
1.3 Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
1.4 [bookmark: _Publish_or_unpublish]Add a Review email address of the team responsible for the page (or update where applicable).
2 Save and check how it looks. If the page displays correctly, publish now (Change the Moderation state to Published and Save), or schedule for a future date.
[image: ]
[bookmark: _Toc17191610]Publish or unpublish a page on a future date
1 Select Scheduling options (not currently available for News story page).
2 Click into the Publish on Date field and select the date to publish.
3 Click into the Time fied and type the time to publish.
4 Click into the Unpublish on Date field and select the date to unpublish (where applicable).
5 Click into the Time fied and type the time to unpublish (where applicable).
6 Click Save to save your page or Preview to preview your new page.
[image: ]
Unpublish (and publish a new version where applicable) on a future date
1 Select Scheduling options (not currently available for News story page).
2 Click into the Unpublish on Date field and select the date to unpublish the current version.
3 Click into the Time fied and type the time to unpublish.
4 Click into the Publish this revision on Date field and select the date to publish a new version (where applicable).
5 Click into the Time fied and type the time to publish a new version (where applicable).
6 Click Save to save your page or Preview to preview your new page.
[image: ]
8 [bookmark: _Add/edit_components_within][bookmark: _Toc17191611]Add/edit components within a page
[bookmark: _Choosing_a_paragraph][bookmark: _Toc17191612]Add a paragraph type 
Some pages such as News story and Standard page have text fields built into their templates to complete. However, they also have additional pararaph types that can be added under Optional componenets, and customised to particula agencies. Other page types, such as the Product page don’t have these text fields built in, and require you to add paragraphs to build the page.  
There are 6 paragraph types to choose from: 
FAQ embed—used to associate FAQs with product pages.
Feature list group—used to create features and benefits in product pages.
Forked content—used to customise content to agencies.
Generic markup—used for general content.
Product comparison group—used in outcome pages to compare products.
View—used to add downloadable documents search functionality (See the Customer Online team for implementation advice).
[bookmark: _FAQ_embed]FAQ embed
Create the FAQ as you would a standard content page.
[image: ]
1 Click > FAQ.
2 Type the Question.
3 Type the Answer.
4 Type the name of the page you want the FAQ attached to in the Associated pages field.
4.1 Add multiple pages by adding a comma and then add the additional pages.

[image: ]

5 Select Meta tags and update the metadata for your new page as required:
5.1 Add Keywords.
5.2 Add Creator (your agency name) under Dublin Core Basic Tags > Creator in the Value field.
[image: ]
6 Select Publishing options:
6.1 Select the appropriate Review frequency (3/6/12 months or Other) depending on the content’s volatility.
6.2 Insert the Review email address of the team responsible for the page.
7 Save and check how it looks. If the page displays correctly, publish.
If you’re creating or editing a product page and need to attach the FAQ to that page, see Add FAQs to the Contact and support tab.
If the page that the FAQ is attached to is already published and has FAQs on it, view the page and make sure your new FAQ appears in the list.
[bookmark: _Create_forked_content]Create forked content
Forked content allows you to customise the information on a page to suit different agencies. You can choose to fork all content, or only certain elements of a page (for example an aside). 
Select the optional component tab in left hand side menu.
Select Optional component type.
Select Forked content > Add new Optional component or Add another Optional component.
[image: ]
Select > Add new Fork. 
[image: ]
1 Type content in the content field.
2 Select the agencies that should view the new content. Leave blank if the content applies to all.
[image: ]
3 Repeat these steps until content has been created for all agencies.
[image: ]
4 Save and check how it looks. If the page displays correctly, publish.
[bookmark: _Add_a_generic_3]Add a generic paragraph
1 Choose Paragraph type > Generic markup. 
2 Select > Add new Paragraph.
3 Type your text into the Content field.
[image: ]
4 Select the agencies that should view the new content. Leave blank if the content applies to all.
[image: ]
5 Repeat these steps until content has been created for all agencies.
[bookmark: _Toc17191613]Cut and paste text into a content field
Cutting and pasting directly from Microsoft Word can result in unnecessary Microsoft formatting code being copied over into Drupal. You can use Notepad to clean text or use www.html-cleaner.com to clean HTML.
Cleaning Word text in Notepad 
(to remove unnecessary Microsoft Word formatting)
Highlight text in word document. 
Copy text (Ctrl + C) from the Word document.
Open Notepad.
Paste (Ctrl + V) into Notepad.
Select text in Notepad.
Copy text (Ctrl + C) from Notepad.
Paste (Ctrl + V) into the content section in Drupal.
[image: ]
Cleaning Word text using www.html-cleaner.com
Highlight text in the Word document.
Copy text (Ctrl + C) from the Word document.
Go to www.html-cleaner.com.
Set up cleaning preferences (use default).
[image: ]
Paste text into html-cleaner (Either side—if a change is made to one side the other side will be updated). 
[image: ]
Select Clean HTML (this will clean any unnecessary Word formatting from text).
Copy and paste clean text into Drupal and the correct formatting should be retained (headings, bolding, etc).
[bookmark: _Toc17191614]Add styling to text
Highlight the text.
Select an option from the content toolbar:
B—Bold
I—Italics
Unordered list—Insert or remove bullet points
Ordered list—Insert or remove numbered bullet points
Numerical point— Insert or remove numbered list
Heading 2— Select from the Format drop-down list.
Heading 3—Select from the Format drop-down list.

For more styling options:
Select Text format > Rich text to change the Styles drop down to a Format drop-down list.
Select the format required from the Styles drop-down menu.
[image: ]
[bookmark: _Toc17191615]Add links to text
Highlight the text. 
Select the link icon.
[image: ]
Under link info > choose the Link type:
URL—web address.
Email—email address.
Link to anchor in text—linking within the page.
Other—modal URL or page element (div) ID.
Enter the link target information.
Click OK.
[image: ]
[bookmark: _Toc17191616]Add a lightbox link to another page
Links can be styled as a lightbox to open content from another page while remaining on the current page. This is beneficial for web forms in particular, as you can show the user other information without losing the fields they have already completed.
Create a link in your content (as above). Under Protocol, select other. In the URL field, enter /modal/ followed by the address of the page you want to show in the lightbox. Select OK.
[image: ]
Highlight the link text. Click the Styles drop-down menu and select Lightbox.
[image: cid:image004.png@01D1C012.6B0B1DD0]
Save and check how it looks. If the page displays correctly, publish.
[image: ]
[bookmark: _Toc17191617]Add a lightbox link to a page element
Inspect the element you want to show in the lightbox (right click and select Inspect element), and note the div ID.
[image: cid:image001.png@01D1C011.F14D7F60]
Create a link in your content (as above). Under Protocol, select other. 
Enter the link target:
If the element is on the same page, enter the hash symbol (#) followed by the target div ID. 
[image: cid:image003.png@01D1C012.6B0B1DD0]
For an element from a different page, enter the page URL followed by ‘/#’ and the target div ID. 
[image: ]
Click OK. 
Highlight the link, click the Styles drop-down menu and select Lightbox.  
Save and check how it looks. If the page displays correctly, publish.
[image: cid:image005.png@01D1C013.1637C3C0][image: ]
[bookmark: _Toc17191618]Add a lightbox link to an image
Links can be styled as a lightbox to display a large image while remaining on the current page. This is beneficial for large images that will extend your content too far down a page if you included them in the body.
1 Add an image via the CMS
2 Insert and then highlight the text or image you want to create a lightbox link from.
3 Select the link icon.
4 Under Protocol, select other. In the URL field, enter /sites/default/files/ followed by image file name (e.g. example-alert-message.png). Select OK.
[image: ]
5 Highlight the link text or image. Click the Styles drop-down menu and select Lightbox.
6 [bookmark: _GoBack]Save and check how it looks. If the page displays correctly, publish.
[bookmark: _Toc17191619]Add a link to content located on Drupal
Highlight the text.
Select the link to content icon.
[image: ]
A Linkit window will open up.
[image: ]
In Search for content field type the name of the page/document to link to.
The Link URL field will automatically be populated. 
Select Insert link. 
The link will be inserted into the highlighted text.
[bookmark: _Toc17191620]Add a table of contents
You can insert a table of contents to improve navigation on long pages. This will reformat your page by:
· Inserting a numbered list in the body and left navigation, with links to all Heading 2s on your page. 
· Numbering all Heading 2s within your page.
· Collapsing text between Heading 2s (fade out over 4 lines) and adding a Read more link.

Add the text [TOC title] to the body at the point where you would like the table of contents located.
Replace title with a heading for your table of contents.
[image: ]
Save and check how it looks. If the page displays correctly, publish.
[image: ]
[bookmark: _Insert_an_image][bookmark: _Add_a_Pull][bookmark: _Toc17191621]Add a Pull quote 
1 Highlight the quote.
2 Click the quote icon.
3 Click the Styles drop down and click Pull quote.
[image: ]
4 Add the quote’s attribute:
4.1 Click Source.
4.2 Find the html for the quote <blockquote class=”pull-quote”>quote here…</blockquote>.
4.3 Before <blockquote class=”pull-quote”> add the html <div class=”figure”>.
4.4 After </blockquote> add the html <div class=”figcaption”>attributate here…</div></div>
4.5 Click Source to return to text-view.
[bookmark: _Toc17191622]Insert an image
There are 2 ways to insert an image into the body of your content:
· Small image: Add through the image button. You can align this image left or write with text wrapped around it.
· Large image: Add through the Source button. You can resize this image and align it as needed to the page, but you can’t wrap text around it.
Small image
1 When editing a page, place the cursor where you would like to insert your image—place it on its own line.
2 Select the Add media icon.
[image: ]
3 Select your image by:
· Upload—Browse and upload the image. Choose Public local files served by the webserver. Edit the name (if required). Add Alt Text and Title Text.
· Web—Type the File URL. Choose Public local files served by the webserver. Edit the name (if required). Add Alt Text and Title Text.
· Library—Search for the image using the file name.
4 Click Submit.
5 To wrap the text, highlight the image and select the Styles dropdown and click:
· Image cut-in right—Aligns the image to the right with text wrapping to the left
· [bookmark: _Embed_a_video]Image cut-in left—Aligns the image to the left with text wrapping to the right.
Note: If you want to change your image from one position to the other, you will need to click the Source button and manually remove the code before applying the new position.
Large image
1 When editing a page, place the cursor where you would like to insert your image—place it on its own line.
2 Select the Link to content button.
[image: ]
3 Search for your content using the title of the image. Select it when it displays.
Note: You’ll need to have uploaded the image to the CMS before searching for it. 

4 Click Insert link.
5 Click the Source button.
6 Find the hyperlink you’ve just created in the source code:
[image: ]
7 Change the <a href> element to <img src>. Delete the image name and the </a> element.


Example
Original:<p><a href="/file/17416/download?token=VNyE1E2o">lightning.png</a></p>
Updated:<p><img src="/file/17416/download?token=VNyE1E2o”></p>

8 To adjust the size of your image and alignment, type the style attribute and add, height, width and/or align.
Example
<p><img src="/file/17416/download?token=VNyE1E2o” style="width:100%;algin:centre;”></p>

[bookmark: _Embed_a_video_1][bookmark: _Toc17191623]Embed a video
You can embed videos on the following page types:
· Standard page
· Event page
· Knowledge sharing group page
· Project page
· News page

Upload your video on a separate hosting platform (such as YouTube or Vimeo).
Note: Do not upload your video file to the For government CMS.

When editing a page, place the cursor where you would like to insert your image—place it on its own line.
Select the Video filter button.
[image: ]
Copy and paste the video URL into the Video URL field.
Click Insert.
Add a video transcript
1 Place the cursor after the video and click the Source button. 
[image: ]
2 Insert the following code snippet beneath the video, where you want the show/hide transcript to appear:
<div class="video-transcript">
[Insert video transcript text]
</div>

3 Save the page and check how it looks. If the page displays correctly, publish. 

[bookmark: _Create_a_Status][bookmark: _Toc17191624]Create a Status alert (warning or information)
Select > New draft to edit the content page. 
Scroll down to the Status alert section.
Select > Add new Status alert.
[image: ]
In the Status alert section:
Add a title.
Add your content into the body.
[image: ]
Select the Status type:
Info—Information that may be helpful to the visitor.
Warn—Warning the visitor of something they need to do or be aware of before continuing.
[image: ]
Save and check how it looks. If the page displays correctly, publish.
[bookmark: _Create_Asides][bookmark: _Toc17191625]Create Asides
Asides are content located on the right hand side of a standard content page. They should contain content that is secondary to the main body content on the page.
Select the optional component tab in left hand side menu.
Select Add new Aside, Add another Aside or Edit existing aside.
[image: ]
[image: ]
Add a Title.
Choose an Aside style from the drop-down menu:
Default—suitable for most types of aside content (most common).
Contact—only used for phone numbers, email addresses or physical addresses.
Emergency contact—for emergency contact details only (000, SES).
Tip—Useful (but not critical) information that may help a visitor.
Events—for highlighting names and dates of events.
Feedback—a way for a visitor to provide feedback to a business area.
Sponsors—for highlighting third party sponsors.
Beta—for indicating that a feature is in beta-testing mode.
Enter aside content. 
[image: ]
Save and check how it looks. If the page displays correctly, publish.
[image: ]
Create a Google Maps aside
Open Google Maps.
Go to the address.
In the top left, click Menu [image: ].
Click Share or embed map.

[image: ]

Click Embed a map.
To the left of the text box, click the Down arrow and select Custom size.

[image: ]

Enter 285 x 285 in the dimensions boxes
Copy the HTML provided and paste it into the aside. (Remember to change the aside text format to ‘Full HTML’ as you’ll need to paste it in ‘source’ view).

The code will look something like:

<iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3539.9044078468046!2d153.02599731584957!3d-27.472235223389852!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x6b915a1b1fd2fd07%3A0x95d1e60f49ab2d39!2s53+Albert+St%2C+Brisbane+City+QLD+4000!5e0!3m2!1sen!2sau!4v1527127426820" width="285" height="285" frameborder="0" style="border:0" allowfullscreen></iframe>

Create a Feature slider aside
You can add a Feature slider aside to a Section page.
1 Select Asides from the menu.
2 Click Add new Slider.
[image: ] 
3 Add a meaningful Title for the aside Feature.
4 Click Add new Slider item.
5 Add a meaningful Title for the Slider item.
6 Add a Summary for the Slider item.
7 Click Browse to add an image. Choose a File and Upload an image, or select an existing image from the Library.
8 Add a link to the content the slider promotes (leave blank if there isn’t further content to link to).
9 Select the agencies the slider should be viewable to (leave blank if it should be seen by everyone).
10 Add additional sliders as required.
11 Select the agencies the aside should be viewable to (leave blank if it should be seen by everyone).
Save and check how it looks. If the page displays correctly, publish.

[bookmark: _Toc17191626]Create a process flow diagram
You can use process flow diagrams to display high-level steps for undertaking a task or set of tasks. These are most effective on ‘Outcome’ pages.
Edit the content page.
Scroll down to the Body field.
Insert H2 ‘Process overview’.
Create an ordered list using the tool bar.
To add a sub-step use an unordered list between the main numbered lists.
End on a numerical ordered list.
[image: ]
Save and check how it looks. If the page displays correctly, publish.
[image: ]
9 [bookmark: _Toc461634814][bookmark: _Upload_a_file][bookmark: _Toc17191627]Upload a file or image
[image: ][image: ]In the CMS menu, open the Content list, then select the Files tab.
Click the Add file button.
[image: ]
To upload your file either:
Click Choose file and navigate to the file location on your computer.
Drag and drop the file into the box next to the Choose file button.
[image: ]
Note: Take note of the allowed file types (extensions) and maximum size.

Click Upload then/or Next.
Select whether the image will be Public or Private and click Next.
· If you are uploading a document or video, your file will appear at the top of the files list.
· If you are uploading an image, update the Name, Alt text and Title text for the image and click Save. Your image will appear at the top of the files list.
Note: You must enter Alt text for informative images (non-decorative).
10 [bookmark: _Toc17191628]Logging out
To log out of Drupal:
Click your Username in the top Toolbar menu.
Click Log out.
[image: ]
11 [bookmark: _Toc17191629]Support
	Drupal support

	Contact the Customer Online team:
Ph: (07) 3035 4410
Email: qsscxdesign@dsiti.qld.gov.au 
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